This is the old SliTaz forum - Please use the main

New Cooking 20091104
  • panksopankso November 2009
    Hi all,

    A new Cooking is now on the mirror!

    Please check it out and make your feedback here, on the list or on the new community platform via the blog-like stories. You can read the website announce for more informations and download the new core, justX or base ISO from Tuxfamily mirror.

    - Christophe
  • pre_historic94pre_historic94 November 2009
    I had no sound using the Cooking 20091104
  • rabidbadgerrabidbadger November 2009
    Disappointed that the 'X only' flavour still has no wireless support - I like to start as clean as possible with any distro, and only add the packages that I actually use :-(
  • PayoonPayoon November 2009
    found, that the print and the print preview function of the firefox 3.53 in the new cooking is not working. Otherwise the browser is very fast. I use this very often, because I print out text from www as pdf files.Now there is still a chance to correct, before stable release. Best regards : Klaus
  • CassianoCassiano November 2009
    I have 2 sound cards here, slitaz recognize then, load the modules, but no sound at all.

    And it is not applying settings for my keyboard (abnt2)
  • PayoonPayoon November 2009
    After spending some time now with the new SLITAZ cooking I have to say hats off. It is a lot faster then my old cooking 2.0. Not only the browser, but also the WM. What I also like is, that the mountbox and package manager open after the first click, whereas in the past I sometimes had to click multipletimes to open the dialog. All in all : Great work.
    The only thing I found didn't work is the print and print overview function in Firefox.

  • panksopankso November 2009

    Thanks for the feedback.

    @Payoon Firefox printing is disabled at compilation time so no printing... I will check with the last release if printing dont slow down Firefox and dont make the package to big other wise we maight have a firfox-full packages with all options enabled.

    For sound issues, I think it is related to udev, so maybe look into /dev/snd, try to request event from the Kernel once booted:

    # udevadm trigger

    And look again in /dev/snd
  • ouioui November 2009

    I also did spend some time to try the new cooking.

    I have following problems:

    gparted recognize my debian-partition (ext4) but the mountbox can not mount it and PCmanFM can't open it

    gparted don't recognize the content of my fat32-partitions.

    And I think about following situation:

    Debian did install the Grub2 boot manager (work very well but is terrible cryptical in my first opinion!).

    It is my first experience with this new boot manager.

    The question is, if I install Cooking now in an other free partition with the complete development system what is to do to complete the installation without error to preserve the access to Debian in all cases because the usual file menu.lst of grub1 is not longer available in Grub2 to copy the correct start parameters in the grub1's menu.lst that Cooking would probably ask to install or to add the right parameters for Cooking in the Grub2 system?

  • ouioui November 2009
    PS: PCmanFM give following error on the ext4 partition:

    Erreur org.freedesktop.Hal.Device.Volume.UnknownFailure
  • pre_historic94pre_historic94 November 2009

    # udevadm trigger

    And look again in /dev/snd

    theres still no others file

  • pre_historic94pre_historic94 November 2009

    I am using jozee's linux-sound- and the sound is working. :)
  • PayoonPayoon November 2009
    Hi folks
    grsync: Just for information: When starting grsync it complains: error while loading shared libraries object file : No such file or directory. To solve it you have to install acl from the repo.

    xine-ui : it doesn't play any video, because it doesn't have any codecs. Where can I download the appropiate codecs ( for wmv, avi, etc.)?
  • panksopankso November 2009
    hi all,

    @oui Kernel dont have ext4 support and we may not enable it by default and wait until btrfs is stable for production.

    @pre_historic94 Nice so we are going to fix and improve official Kernel.

    @Payoon First thanks for the feedback. Grsync missing dep fixed: For Xine, strange it should read avi out-of-the-box, I just tested and can reproduce the bug so going to investigate, please try MPlayer with the package mplayer-codecs.

    - Christophe
  • ToffToff November 2009
    Hi, using cooking from live usb :

    - samba requires libldap-2.3 but libldap provides libldap-2.4

    - cups requires acl

    Is it normal that samba requires perl ? maybe it should be in suggested package only as it's already pretty big ?

    It would be nice also to enable xmlrpc support in rtorrent, so it's possible to use some webUI like wtorrent or rutorrent.

    Thanks for making slitaz.
  • kultexkultex November 2009
    I want to say the same as Payoon - "hats off !!!" - but some problems

    1) On the Asus Nova Lite EP20 the Atheros Network card is now on board, but it does not connect to dhcp - to get it working, I had to run ifconfig eth0 up - with netbox I did not manage.

    2) All the get-opera, openoffice ... scripts work only from the CD and not if installed on the stick. This is a bit a problem, because if you want download openoffice and afterwards save it with tazusb you need a lot of memory or you cannot say after 2 month - oh I want goole-earth now, without starting from the beginning.

    3) get-google-chrome and get-openoffice are not working - google-chome seems to be installed - there is a menu entry, but unable to open - openoffice starts to download, but after downlod the xterm window closes - I have no idea why, but perhaps a problem of language (german). Generally it would be nice, to let the xterm window open after finishing - so you dont have to sit at the PC to control it.
    Is there something, where all this outputs are protocolled?
  • kultexkultex November 2009
    ok - just found that when installed on a stick, I have to run get-OpenOffice3 from the terminal

    but it is still braking and I see now, what is the problem - it downloads everything to /tmp, which is not good, because it is in the ram - and eaven with 512MB it is crashing.

    Why not write it to /home/tux/.tmp do everything there (ok might be quite slower) and just on the end, when installing, it goes to /

    the funny thing is, that you do not see anything in htop or LXDE - Taskmanager - it stays all the time on 38MB - you just see it in pcmanfm in /tmp - there it counts down (strange)

    and google-chrome is still not working

    and by the way - just an idea - replacing LXDE - Taskmanager with htop - LXDE-Taskmanager shows nothing and is eating only CPU power - on my Alix it is 7 - 9% compared to 2% with htop
  • PayoonPayoon November 2009

    Hello everyone

    just for info : epdf from the repo needs one more dependenciy: lcms

    I have to say the speed of the cooking is amazing. What I do not understand is, what is the reason for the big speed difference?.
    Anyway it's a pleasure to work with Slitaz. And I use it everyday.
  • kultexkultex November 2009
    Atheros Network card on the Asus Nova Lite EP20 is now working on startup - no idea, why it did not connect on Saturday - but the EP20 starts to make troubles (also the burner and VGA - sometimes they work, sometimes not) - I think it has to go for service.

    I tested cooking today on my Kino Atom (which has the same ingredients as the Asus EEE-box) - the RTL8111/R8168B Networkchip is not recogniced, its also not in the repos - at least I did not find anything.

    and the display resolution is very strange - max. 800x600 - the grafic chip is Intel Mobile 945GSE.
  • jozeejozee November 2009
    @Payoon: thanks, epdfview dependency poppler updated with lcms:
  • minimalist1minimalist1 November 2009
    Hi, Slitaz is great!
    HP celeron 1.7Ghz, 1.5Gb, intel 810, creative notebook web cam (works with 2.6.31 in Ubuntu with usbv drivers).
    USB install.
    Some problems with: Multimedia (none of the players worked) "if you are using" the mainteiner missplaced some files and will be fixed later.
    Haven't reinstalled to see if it is my problem.
    Skype not working nor the web cam is recognized. Will try again to rule out problems at my side.
    The cam is cheap and works great with cheese and skype. Mechanically not very good (I had to lego-ed someting to make it turn and move up and down) but low cpu and great vid.
  • jozeejozee November 2009
    @minimalist1: For multimedia players, please recharge and upgrade. Mplayer/Smplayer problems were fixed. VLC is working fine. Gnome-mplayer is still giving some problems at my end in the new cooking (don't know why yet). For webcams, make sure you install linux-video pkg and then modprobe gspca_main/uvcvideo (whatever webcam you have)
  • minimalist1minimalist1 November 2009
    @jozee: thanks,
    removed xine; reinstalled mplayer and installed VLC. Tested with a flash video from youtube. None of the players worked.
    linux-video alredy installed but no gspca module was found.
    Skype is working.
    At this point I think that my install is the problem.
    I will download stable and cooking to check them tomorrow.
  • nordviksnordviks November 2009

    I have a laptop that has a non working LAN port, but an Intel 2200bg wireless card. I tried all the different versions on the ftp (used unetbootin) but I could not get Slitaz to recognize my wireless card. Is it possible for me to use Slitaz?
  • flOpflOp November 2009
    As usual, Slitaz is incredibly fast and lightweight : thanks a lot :-)

    However, as minimalist1, I have pb with xine or mplayer ! I can't open neither of them, there is no reaction from the computer... I tryed to recharge & update but it didn't solve the pb.

    Have you any idea of the pb or a solution ?

    Best regards,

  • jozeejozee November 2009
    How about mplayer-svn and SMplayer? Both works for me
  • flOpflOp November 2009
    Even after a list refrefh in tazpkg box, mplayer-svn seams to have a dead link (can't download) !
    I can open SMplayer but I am unable to play a file (mp3, avi) because many libs are missing:, ...

    VLC seems to be the only player to work !
  • babaorumbabaorum November 2009
    mplayer is perfectly running if you manually complete the lib dependences missing...
    It is a matter of a few minutes only, reading the error messages from running mplayer in command-line: you have two cases:

    A ) look for any libfile already existing with an approaching same name:
    ls -l [libfile basename]*
    As this, you may see that lib is already installed but refering to a newer version that one required by mplayer... simply make a symbolic link to existing lib, naming this symbolic link as the libfile required by mplayer, and pointing to the existing libfile.
    ---> in root mode:
    ln -s [name of existing libfile in newer version] [symbolic link:name of libfile as required by mplayer]

    B ) you do not find any libfile, you must look for it in packages files, using command-line tazpkg:
    tazpkg search-file [libfile basename]
    or GUI wrapper for Tazpkg: "search" tab, "Files" button
    ... and install the package containing the searched libfile:

    - commandline (in root mode): tazpkg get-install [package name]

    - GUI: just click on the line where your searched libfile show the corresponding package name ;)

    I hope that it will help you a bit, mplayer is just lightweight and so cool w/o any GUI, associating video files w/ the simple "mplayer %s" command-line launcher...

    Oh yeah... you should try different video output:
    if "mplayer" just works but do not display and video on screen, you may try: mplayer -vo x11 [videofile name]
    If it solves the missing video display, add this to your mplayer commandline configuration file ("$HOME/.mplayer/mplayer.conf"):
    So that it is your default choice everytime you fire mplayer up from command line (GUI wrapper conf files are differents, but in same "$HOME/.mplayer/" directory.

    -- Babaorum
  • babaorumbabaorum November 2009
    For some mysterious reason, libfiles where not found in command-line mode, but they were from GUI wrapper... (last fresh Cooking Live CD from oct.2009) so if your don't find libfiles at all in command-line way, try the Tazpkg GUI ;-)
  • flOpflOp November 2009
    Thanks a lot for your help ! It is very clear & detailed, I think you guess I am quite noob at linux world :-p

    I have already try to manually complete libs via Tazpkg GUI but I stoped after 2 libs because I didn't know how many there had to be installed.. I will try again (tomorrow) and finish the entire processus even if there is a lot of libs to install !

    When you say "mplayer is perfectly running if you manually complete the lib dependences missing", it is exactly what you have done in order mplayer to work ?

    It is strange that so many libs are missing from mplayer package.. Is this due to the november cooking version wich has less integrated libs than stable version ?

    Have a nice day,

  • jozeejozee November 2009
    @flOp: Yes, you are right that you are not suppose to manually compile (unless you know how to do it; its also very easy in slitaz). Tazpkgbox GUI installation of mplayer should pull all the dependencies.

    As slitaz cooking repos are growing, some packages auto-detect new functionalities and require certain new libs. So, sometimes packages do break. But they are really easy to fix; so just report them; they will be fixed asap.

    Anyways, Mplayer/mplayer-svn were updated just after the cooking release .

    But, new mplayer/mplayer-svn may not have been pushed to mirrors yet bacause of some of the mirror issues we are currently having at the backend.

    Meanwhile, you can download from here ( and see if it works for you. Also download Smplayer (I love it). [tazpkg install pkglocation]
  • babaorumbabaorum November 2009
    flOp wrote:

    When you say "mplayer is perfectly running if you manually complete the lib dependences missing", it is exactly what you have done in order mplayer to work ?

    Yup, this is precisely what I have done myself. I can remember they were more than two lib dependencies unsolved, that I had to fix manually just the way I've explained.
  • flOpflOp November 2009

    As baborum, I just add manually "xorg-libXss" ( & "xorg-libXxf86vm" ( and now mplayer works perfectly ! Thx a lot :-) It should be a good idea to add them to the mplayer pkg.

    What about mplayerplug-in pkz ? This one disapperead from mirrors & I couldn't grab the wok because slitaz labs is down..
  • juergenjuergen November 2009
    first I want say thanks for this excellent work. I just updated my "stable" with the "new cooking" and got some small problems:

    1. With the new kernel it can not find my sound card anymore. Still works fine with the old kernel.
    2. During boot it complains that it can not find my swap partition, but it is still there (nothing has changed)
    3. After the update my wallpaper has disappeared. When I try to call "Preferencias/Desktop Wallpaper" it just open a X-terminal with the message "can't execvp -e: No such file or directory"
  • juergenjuergen November 2009
    Sorry, seems there is no edit function for my last posting. Just on more info regarding the wallpaper. After I added a wallpaper icon to the desktop and changed his properties I could start the wallpaper manager. But still the same problem when I try to start it from the menu. So it seems to be a permission issue. I also changed permission from the pcmanfm-pref.desktop in the home directory but no success. Hope somebody can guide me to the right corner. Thanks.
  • mbgmbg November 2009
    Hi there. Let me begin by telling that the day I found SliTaz (yesterday, actually! :-) ) was one of the best days of my life. Many, many moons ago (about 300 of 'em) I purchased a dual Pentium Pro 200 system. But for the last several years this box was just collecting dust because there simply are no operating systems anymore that run either decently.... or at all. Came SliTaz to the rescue!

    But I ran into a problem that left me stuck between a rock and a hard place. First I downloaded 2.0, only to find that every time I start Firefox, the entire system freezes right about after Firefox's window tries to paint. OK, move on to the cooking version. That one works just fine, but it no longer installs drivers for my Promise Ultra 133 TX2 hard disk controller, and so I can't access my drives any longer.

    So here's my question: can you put support for this HD-controller (aka PDC20269) back into the new version of SliTaz. It would really save my day!
  • pre_historic94pre_historic94 November 2009
    Someone please repair the official linux-sound.tazpkg. My computer still had no sound.
  • slicelslicel December 2009
    "1. With the new kernel it can not find my sound card anymore. Still works fine with the old kernel. 2. During boot it complains that it can not find my swap partition, but it is still there (nothing has changed) 3. After the update my wallpaper has disappeared. When I try to call "Preferencias/Desktop Wallpaper" it just open a X-terminal with the message "can't execvp -e: No such file or directory""

    3.The yes/no setting for xterm is wrong in wallpaper's desktop file and needs to be fixed. I and someone else posted details on the old forum but I noticed that the last cooking upgrade broke the wallpaper again.

    1.I reported an inconsistency in the sound files on the old forum but I do not remember the specifics.

    2.I noticed that too but do not know the explanation.
  • sysiossysios December 2009
    Hello. I'm new in Slitaz. I'm trying to install Flash Player with "get-flash-plugin" install and Flash doesn't work. Why? How can I repair it?
  • sporkspork December 2009
    You need to reinstall the get-flash-plugin in tazpkg...

    tazpkg get-install get-flash-plugin --forced

    ...then run the script. The package in the repository is fixed compared to the one in 2.0 (and cooking, I think?).

  • CassianoCassiano December 2009
    Well, i have to get back to stable 2.0 version because of a lot of problens.

    It is impossible to use it whitout a sound card and suport to my keyboard :(

    To bad, i really liked this version, faster, prettier but no sound :P
  • DeanDean December 2009
    Dear forum members,

    I have been struggling for few days trying to install Slitaz cooking ISO,kernel2.6.30.6. Burn on CD. USB drive booting no problem. CD boots, no problem. Install on hard drive-can't.

    My system

    -acer netbook-160GB/triple boot(xp/ubuntu9.10/ubuntu UNR9.10)

    -ubuntu9.10 upgraded from version 9.04/ grub is upgraded to grub2.

    -install on /dev/sda10..... and.... ext3/ no grub installed as I used already existing.

    This is what I put as brub config:

    title SliTaz GNU/Linux (cooking) (Kernel

    root (hd0,9)

    kernel /boot/vmlinuz- root=/dev/sda10

    I got this error at boot time:

    Error 15: File not found

    Now,I did grub edit the file /etc/grub.d/40_custom using the following command.

    sudo gedit /etc/grub.d/40_custom

    sudo update-grub

    Result: No slitaz shown at boot time.

    As, it doesn't work, I did clean install of Ubuntu 9.10 and grub2. After this, I can't boot my system. Error message. Reinstall my Ubuntu 9.10.

    Help: how to install to boot with grub2 from ubuntu 9.10. please help me what configuration lines should be put in the grub2? ANOTHER big problem- in grub2, now I cannot see my configuration.
  • kultexkultex December 2009
    when I change the password for tux in the control box, the pw is always: root, whatever I give in - it is only changeable afterwards with: passwd tux on the console
  • a0rovea0rove December 2009
    Have a lot fun to use it! But I got some bugs after I installed it into harddisk:

    1. it found my swap partition and add it into /etc/fstab. Next time I got a error say "swap: no such file or directory"
    2. I installed xorg,
    and got a error when tazx try to patch xorg.conf.
    X can't run until I remove file /dev/dri and add a directory /dev/dri
    3. I don't know why "udevd --daemon" always fail when bootup, but it works...
    4. After I installed wget, there is a problem in get-flash-plugin and get-opera (I changed wget -s to wget -q)

  • a0rovea0rove December 2009
    5. can't install virtual-box, it seems that the script get-virtualbox is not correct
  • seawolfseawolf December 2009
    @a0rove -- With regards to your swap partition, could you post the line you added to fstab and your partition layout please? Something like the following will be useful:

    /dev/sda3 . . . . . swap . . . . . swap . . . defaults . . . . 0 0

    sda1 - 20GB, ntfs, Windows XP

    sda2 - 20GB, ext3, Slitaz cooking

    sda3 - 2GB, swap

  • a0rovea0rove December 2009
    /dev/sda9 swap swap default 0 0

    Device Boot Start End Blocks Id System

    /dev/sda1 * 1 5222 41945683+ 7 HPFS/NTFS

    /dev/sda2 5223 7833 20972857+ 83 Linux

    /dev/sda3 7834 11750 31463302+ af Unknown

    /dev/sda4 11751 19452 61866315 5 Extended

    /dev/sda5 11751 14361 20972826 c Win95 FAT32 (LBA)

    /dev/sda6 14362 16972 20972826 83 Linux

    /dev/sda7 16973 19061 16779861 83 Linux

    /dev/sda8 19062 19323 2104483+ c Win95 FAT32 (LBA)

    /dev/sda9 19324 19452 1036161 82 Linux swap

    I got the error when rcS run "mount -a"

    6. I can't build the kernel. It seems that there is no dir "fs/aufs" in kernel code tree...

  • seawolfseawolf December 2009
    Perhaps 'default' should have an 's' on it else it won't be parsed as a valid FS option... maybe. Hopefully someone can confirm this or have any other ideas? Can you mount the swap from the command line manually?

    6. I personally download the standard kernels from
  • a0rovea0rove December 2009
    I changed the 'default' to 'defaults', still got same problem. So I just redirect the error when boot up the system.
  • a0rovea0rove December 2009
    7. smbclient: error while loading shared libraries: cannot open shared object file: No such file or directory. Current libldap is libldap-2.4
  • babaorumbabaorum December 2009
    This is "default"

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social