This is the old SliTaz forum - Please use the main

start with xfce
  • mohikanmohikan February 2010
    hi everybody

    I installed xfce with "tazpkg get-install xfce4"
    how can I change settings to start xfce
    and, I need to change keyboard map to tr_q-latin5, I couldn't fınd how can I install the keymap

  • LuXLuX February 2010
    Hello Mohikan,

    in order to make xfce the default window manager in Slitaz Cooking, I think that you can simply edit /home/tux/.config/slitaz/applications.conf and change the line concerning the window manager from:
    # Window manager.

    # Window manager.

    Note that you can also choose a different window manager while you are in front of slim's login window: pressing the F1 key repeatedly should display you "openbox", "e17", jwm", and so on until you find xfce4. If the last one is not displayed it suffices to add it in the list of available sessions in /etc/slim.conf. Here is the corresponding part of mine (you can see that I don't use xfce with Slitaz):
    # Available sessions (first one is the default).
    # The current chosen session name is replaced in the login_cmd
    # above, so your login command can handle different sessions.
    # see the xinitrc.sample file shipped with slim sources
    sessions openbox,e17,jwm,dwm,awesome

  • mohikanmohikan February 2010
    thanks lux
    xfce is not big deal , and it couldnt solve keymap problem :(
  • mojomojo February 2010

    This might solve your keymap problem :

    Download the tinycore extension kmaps.tce

    Do the following steps as root:

    tar -xvf kmaps.tce

    This will extract a single folder named usr in the current directory.

    Descend into the extracted usr folder then share,and finally kmap to find 147 .kmap files including tr_q.latin5.kmap

    Copy the tr_q.latin5.kmap file to /usr/share/kmap folder of your slitaz system

    Menu/Preferences/Keyboard Mapping



    Highlight the new keymap , Click OK

    Logout and Login

  • mohikanmohikan February 2010
    but it didn't work :(
    keymap list doesn't refreshed with new keyboardmaps.

    I am login as root, can it be problem
  • chompachompa February 2010
    thanks for the info
  • mojomojo February 2010
    We have to add the keymap to tazkeymap

    subox geany /sbin/tazkeymap

    Line 72 put my cursor at the end of "sg-latin1" "Singapore" \ hit Enter for a new line.

    Paste this "tr_q-latin5" "Turkey" \

    Click Save

    subox tazkeymap

    Scroll towards the bottom

    tr_q-latin5 Turkey should now be listed below Singapore and above United Kingdom

    Highlight click OK


    If the keymap from tinycore is wrong move or delete it and try generating your own as root

    This idea is from the Keyboard section of

    root@slitaz:/bin/busybox dumpkmap > /usr/share/kmap/tr_q-latin5.kmap

  • ozgurozgur April 2010
    Sorry, there is no use this instructions did not solve the problem. Keyboard seems "tr_q-latin5" but keeps on wting in US.
  • dmatrixdmatrix April 2010
    # loadkmap < /usr/share/kmap/{choice keymap for load}
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social