This is the old SliTaz forum - Please use the main

(SOLVED) Glxgears root vs not as root
  • sanger440sanger440 January 2011
    I have stable v3 running on a P4 desktop with a ATI radeon 9600 video card.  I followed the wiki and I believe I have the video drivers installed and working properly.  However, if I run glxgears -info as root, I get a real high fps (2000 fps).  If I run glxgears - info as tux (user) my fps is like 180.  I have added tux in the video group, add drm module to load at boot, everything in the wiki.  I installed from the command line as root.

    as root  glxinfo | grep render   yields  direct rendering: yes   Opengl render string: Mesa Dri 300 200060815 AGP 4x....

    as Tux  glxinfo | grep render   yields  direct rendering: yes   Opengl render string: Software Rasterizer

    Can anyone confirm if this is normal or should glxgears run fast as tux user also.

  • Trixar_zaTrixar_za January 2011
    SliTaz defaults to using Software rendering with OpenGL, which is probably why you see the huge number difference between the root and tux results.

    This is a common issue with SliTaz, but it is fixable since there are people that have gotten the latest cooking to use direct hardware rendering like it should - I tried searching for the link, but it didn't come up - this forum needs a better search function :P
  • mojomojo January 2011
    Verify tux is member of video group.
    tux@slitaz: cat /etc/group
    If not
    root@slitaz: addgroup tux video
    Post output from this:
    tux@slitaz: LIBGL_DEBUG=verbose glxinfo | grep render

  • sanger440sanger440 January 2011
    I have addgroup tux video a couple of times
    cat /etc/group  shows  video:x:8:tux

    tux@slitaz: LIBGL_DEBUG=verbose glxinfo | grep render   shows libGL: OpenDriver:  urs/lib/dri/
    drmOpenDevice: open result is -1, (permission denied)

    Pretty new to linux, how do I cut and past from an xterm or where is the log file I can open tocut and paste from?

  • Trixar_zaTrixar_za January 2011
    You could try using sakura as your terminal instead of xterm. You can copy and paste from it more easily.
  • sanger440sanger440 January 2011
    Section "DRI"
         Mode 0666

    Load  "drm"

    I added the above to my xorg.conf file and now glxgears works in user (tux) mode.  glxgears -info now over 2500fps.
    This may be the first time in linux I got a 3d driver installed and working right!

    How do I mark this thread as SOLVED?

  • mojomojo January 2011

    Permissions on /dev/dri/card0 root:root so tux can't open.

    Add udev rule below will change /dev/dri/card0 root:video

    tux as a member of group video will then be able to open device.

    You can use leafpad as root if you prefer instead of nano.

    root@slitaz: nano -B /etc/udev/rules.d/50-udev-default.rules

    Add whats in bold:

    # graphics
    KERNEL=="agpgart", MODE="0600", GROUP="video"
    KERNEL=="pmu", GROUP="video"
    KERNEL=="nvidia*|nvidiactl*", GROUP="video"
    KERNEL=="card[0-9]*", NAME="dri/%k", GROUP="video"
    SUBSYSTEM=="graphics", GROUP="video"
    SUBSYSTEM=="drm", GROUP="video"


    tux@slitaz:~$ ls -l /dev/dri/card0
    crw-rw---- 1 root video 226, 0 Oct 11 00:06 /dev/dri/card0
  • sanger440sanger440 January 2011
    Thanks Mojo

    I went ahead and did your fix too.  All seems to work

  • Trixar_zaTrixar_za January 2011
    If you want to change the title, go to your first post and click edit. You should be able to change the title of the topic now :P
  • kultexkultex January 2011
    just as a reminder - this works in stable, but not in cooking

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social