This is the old SliTaz forum - Please use the main

usb 3g modem: can't find it in /dev/tty*
  • SourcererSourcerer December 2010
    3G modem ZTE MF 100. In my Lucid Lynx it works without any problems as /dev/ttyUSB2
    But in SliTAZ... I tried modprobe with some options from forum and wiki :( No effect.
    May be somebody have this usb stick and use it with slitaz?
  • SourcererSourcerer December 2010
    p.s. i did
    tazhw setup 3g-modem
    but it can't find any 3g modems :(
  • ms3811ms3811 December 2010
    I think you will need to install the package linux-dialup.

    # tazpkg get-install linux-dialup


    modprobe option

    This should detect your 3G modem. Then to dial out, you could use wvdial,

    # tazpkg get-install wvdial

    You will need to create a dial up script for your provider, then run "wvdial scriptname" to connect.
  • SourcererSourcerer December 2010
    "modprobe option" gives an error "module option not found"
  • erniaernia December 2010
    in my system it get installed from linux-dialup, did you tazpkg get-install linux-dialup ?
  • SourcererSourcerer December 2010
    I downloaded linux-dialup- from repo and installed it properly.
    But i can't see any ttyACM or ttyUSB deices. Gnome-PPP can't find modems too :(
  • mojomojo December 2010
    Install usbutils.tazpkg
    Run with 3g modem plugged in.

    Post the complete output.
  • ms3811ms3811 December 2010
    @Sourcerer, while you are at it, also run:
    uname -r
    and check what kernel version you are running (rather, make sure it is 2.6.30).
  • SourcererSourcerer December 2010
    It is 2.6.34, i'm using slitaz-cooking
  • SourcererSourcerer December 2010
    Phew. It seems, i need newer versions of linux-dialup
  • ms3811ms3811 December 2010
    :), exactly. Seems like you are running cooking, which means you will need the linux-dialup package from cooking. You could download it from the packages database, just make sure you select cooking from the option. Better way to do it is using System Tools --> Package Manager. You can also do it using the command line,
    # tazpkg get-install linux-dialup
    This will download and install the correct version for you. You may want to remove the package you already have installed before proceeding, although it shouldn't really affect it -- but you never know.
  • SourcererSourcerer December 2010
    people! i love you! it works!
  • stopstockstopstock December 2010
    i have the same problem.

    i use Huawei E620

    i do modprobe, and i've got this message

    root@slitaz:/home/mine# modprobe option Huawei E620
    insmod: cannot insert '/lib/modules/': unknown symbol in module
    modprobe: failed to load module option: No such file or directory

    anyone can help me to solve this problem?
  • erniaernia December 2010
    output of uname -a ?
  • kultexkultex December 2010
    @stopstock because the command is just: modprobe option
  • Trixar_zaTrixar_za December 2010
    Not all 3G modems work well, even if option has the ability to import new product/vendor ID's (What shows in lsusb with a : between the numbers). I'm working on converting over the betavine connection manager beta 3 (used to be called vodafone connection manager) to help with this. Hopefully I'll have something for you guys soon (and I'll finally be back on SliTaz).
  • kultexkultex December 2010
    @Trixar_za - perhaps the sakis3g script is an alternative for slitaz - I did not have time to test it ...
  • stopstockstopstock December 2010
    @ernia -
    i use slitaz stable
    and this is the output of uname -a

    Linux slitaz #1 SMP Sun Mar 28 16:39:51 CEST 2010 i686 unknown

    @kultex -
    i just follow the instruction on
    there is wrote - modprobe option (Huawei E220, E160g, Venus-VT12)

    @trixar_za -
    previously, my E620 is detected normaly on my slitaz.
    and then I tried to change the display screen with sexy desktop, then i installed wbar, tint2, nitrogen, cairo-clock.
    and now, my Huawei E220 that i normally use now cant detected on my slitaz too.

    *im sorry for my bad english*
  • erniaernia December 2010
    if there is nothing wrong with your system kultex is right, and the guide (written by Kultex if i remember well :-) ) reports the modem requiring modprobe option between parenthesis and not as a parameter to the module.
    if modprobe option alone does not work too try to reinstall linux-dialup
    tazpkg get-install linux-dialup --forced
  • kultexkultex December 2010
    @stopstock "modprobe option (Huawei E220, E160g, Venus-VT12)" means you have to do "modprobe option" for the Huawei E220, E160g etc (the 620 uses also the module option). But there exist also Huawei modems with other drivers - not for all you do "modprobe option" - see with "lsmod" if the module option is really loaded - it should look like this
    Module                  Size  Used by
    option 24896 0
    usbserial 29576 1 option
    and then plug in the modem and give the output of the last lines of "dmesg" - it should look like this (my e220)
    usb 3-2: new full speed USB device using uhci_hcd and address 3
    usb 3-2: New USB device found, idVendor=12d1, idProduct=1003
    usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    usb 3-2: Product: HUAWEI Mobile
    usb 3-2: Manufacturer: HUAWEI Technologies
    usb 3-2: configuration #1 chosen from 1 choice
    usb-storage: probe of 3-2:1.2 failed with error -1
    usbcore: registered new interface driver usbserial
    USB Serial support registered for generic
    usbcore: registered new interface driver usbserial_generic
    usbserial: USB Serial Driver core
    USB Serial support registered for GSM modem (1-port)
    option 3-2:1.0: GSM modem (1-port) converter detected
    usb 3-2: GSM modem (1-port) converter now attached to ttyUSB0
    option 3-2:1.1: GSM modem (1-port) converter detected
    usb 3-2: GSM modem (1-port) converter now attached to ttyUSB1
    usbcore: registered new interface driver option
    option: v0.7.2:USB Driver for GSM modems

  • stopstockstopstock December 2010
    i was, but reinstall linux dialup is not working.

    i thought i must do Modprobe when i use another modem :lol:
    thanks for the explanation

    @ all, now i know why slitaz didnt recognize my E620.
    slitaz detected my modem as CD-ROM.
    and is there any usb ModeSwitch for slitaz?

    *im sorry for my bad english*
  • kultexkultex December 2010
    there are two ways of switching the modem in Linux (but there are some modems like the E220, where the info is already in the kernel, so you do not nedd neither hal nore usb_modswitch)

    first is hal with hal-info - second is usb_modswitch

    Slitaz decided for hal with hal-info (did you install hal-info - because this normally is done by tazhw)

    it might be that the the E620 is not in hal-info of 3.0 so perhaps you can try to download and install the cooking package manually - - it should not make any troubles

    as hal is now deprecated, with functionality being merged into udev - see - the last hal-info is from 2009 - i think, it would be good to switch for new cooking to usb_modswitch

    as soon as I have time, I will try the sakis3g script with integrated usb_modswitch......

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social