This is the old SliTaz forum - Please use the main

Problems with sound card and serial mouse
  • FabianFabian March 2010
    Hello, I tried to install SliTaz on a celeron 466 and I found that does not even sound card recognized.
    The sound card is c-media cm8338, when I see the settings in the computer recognizes what type of plate has but does not work.
    Another problem is that does not recognize the serial mouse, put one usb but wanted to know if you can configure the other.
    Everything else is going great.
  • mojomojo March 2010
    Which slitaz version you use stable-2.0 or cooking-20100221 ?
  • FabianFabian March 2010
    Sorry, Stable 2.0.
  • mojomojo March 2010
    1. External speakers connected, on,verified as working ?

    2. Menu/Multimedia/AlsaMixer:
    Card: what is listed ?
    Master,PCM,Wave sliders all up,turn off mute(00=yes+green)at base of every bar. M key toggles mute,left/right arrow keys highlight active control.
    Up arrow=Up Volume

    3. Open xterm,become root:
    root@slitaz: tazhw detect-pci


    Does it show >Module in use: snd_cmipc

    root@slitaz: soundconf

    Does menu list your card ?

    If yes click ok.

    Google said the module for the cm8338 is snd-cmipc:

    5. See if it's loaded:
    lsmod | grep cmipc

    6. Still no Sound :
    post output from
    lspci | grep audio

  • FabianFabian March 2010
    When I use soundconfig have two lines of text, the cm8338 and a second line that says:

    Legacy probe legacy ISA (non pnp) chips.

    The whole procedure that says, soundcard detected correct, but still no sound, the volume control is disabled.

    (On this computer I installed win 2000 and the sound works right.)

  • mojomojo March 2010
    I've put bold numbers by each step above.

    You want slitaz sound you still have more work to do.

    Report back exactly what happens on step 3.

    Step 1.Speakers OK since sound works Win2k
    Step 2,Can you open alsamixer ? What do you mean by volume disabled ?
    Step 4. Soundcard is recognized,ignore legacy ISA, it always appears.
    Step 5. DO AFTER STEP 3
    Step 6. DO IF SOUND STILL BROKEN copy from terminal to comment

  • FabianFabian March 2010
    hello again, I detail the steps I followed the instructions according:

    2. I open alsamixer and configure the controls, the volume control panel on the desktop is crossed and if I enable it again disable

    3. tazhw detect-pci

    Detected pci devices kernel modules

    Missing module: sis-agp
    module in use: ohci_hcd
    Mudule in use: snd_cmipci

    4. root@slitaz: soundconf

    search soundcards

    Following cards are found on system

    cmipci C-media electronics inc CM8338A (rev 10)

    the module in /lib/modules/ is snd-cmipci

    5. lsmod | grep cmipc
    snd_cmipci 28900
    snd_pcm 52356
    snd_opl3_lib 9216
    snd_mpu401_uart 6784
    snd 39096

    gameport 10380

    6. lspci |grep audio

    00:0f.0 Multimedia audio controller: C-media electronics inc CM8338A (rev 10)

  • paulidalistepaulidaliste March 2010
    oh a great tutorial but if you could help me with this

    snd via82xx sound module...

    i did everything just like in this tutorial and it shows me after grep audio that i have via AC97 audio controller but still it doesn`t work

    please help
  • mojomojo March 2010
    Please paste complete output from all commands below
    Open two xterms,become root in one stay tux the other.Run each command in both terminals,if output differs post both indicating which users output .

    lsmod | grep snd

    Here's mine:
    root@slitaz:/home/tux# lsmod | grep snd
    tux@slitaz:~$ lsmod | grep snd
    snd_ymfpci 52644 1
    snd_opl3_lib 9216 1 snd_ymfpci
    snd_hwdep 6916 1 snd_opl3_lib
    snd_mpu401_uart 6784 1 snd_ymfpci
    snd_rawmidi 17440 1 snd_mpu401_uart
    snd_seq_device 6540 2 snd_opl3_lib,snd_rawmidi
    gameport 10380 1 snd_ymfpci
    snd_ac97_codec 86564 1 snd_ymfpci
    ac97_bus 2432 1 snd_ac97_codec
    snd_pcm 52356 2 snd_ymfpci,snd_ac97_codec
    snd_page_alloc 7944 2 snd_ymfpci,snd_pcm
    snd_timer 17416 3 snd_ymfpci,snd_opl3_lib,snd_pcm
    snd 39096 11 snd_ymfpci,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer
    soundcore 6216 1 snd

    8.Try to play a small wav file
    aplay -vv /path/to/wav

    aplay -l

    cat /proc/asound/cards

    cat /etc/group

    ls -la /dev/snd

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social