This is the old SliTaz forum - Please use the main

[BUG] mount is broken in cooking
  • malamutmalamut March 2011

    I try to mount my flash drive with command:

    mount -o codepage=cp1251 /dev/sdb1 /mnt

    And get an error in /var/log/messages:

    user.warn kernel: XFS: unknown mount option [codepage]

    Ok, no problem, if mount is so stupid - specify a FS type:

    mount -t vfat -o codepage=cp1251 /dev/sdb1 /mnt

    But error still here! Mount utility still try to mount my drive as XFS, but must try to mount as VFAT.

    Moreover, -s option also doesn't working in cooking Slitaz!

    So I simply can't change codepage for my fat drives - they can be mounted only with default settings.

  • Trixar_zaTrixar_za March 2011
    No, it's not broken. Busybox's mount command just doesn't support the option codepage.

    Why do you use such an obscure encoding with your flash drive? My flash disks are formatted as FAT32 and my secondary hard drive is formatted in NTFS. Both mount fine for me. Maybe try formatting your drives with Windows's Format function or SliTaz's GParted to FAT32 or NTFS without the encoding.
  • malamutmalamut March 2011
    It's look like default Russian Windows encoding for fat32, I can't change it unfortunatelly - I should work with national filenames at USB drives in slitaz, but can't format this drives into different FS. May be there is some workaround for supporting codepage and other options? Now I see a lot of ???? in my terminal at all flash drives with national filenames((
  • Trixar_zaTrixar_za March 2011
    The only option is to find and convert over the real mount command to replace the one provided by busybox. Here's a copy of debian's mount package I converted over and cleaned up a bit: - no guarantee it will work, but it's worth a shot. You can install it with the tazpkg install package.tazpkg command.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social