This is the old SliTaz forum - Please use the main

Allegro on slitaz
  • grandagranda March 2011
    Hello there.
    I'm trying to compile Allegro 5.0.0 on slitaz 3.0 stable.
    But it give this
    The libxrandr-dev is already installed.
    Any idea?

    error.txt 3K
  • panksopankso March 2011
    Didn't try on stable but on latest cooking Allegro compile nicely, if I have time I will do a package for it. Note you need mesa and libglu-mesa installed.
  • grandagranda March 2011
    I already have mesa and libglu-mesa installed, but i cant compile allegro D:

    If u can do a package, i'll be grateful (:

  • slicelslicel March 2011
    I noticed a number of people with compile problems on slitaz 3 stable.
  • grandagranda March 2011
    I must install the cocking version?
  • Trixar_zaTrixar_za March 2011
    @granda - Maybe. You're missing several packages going on your error log. The easiest way to get all of them would probably be to install slitaz-toolchain and slitaz-dev-pkgs. Then try compiling again.

    slitaz-dev-pkgs should install most of the dev packages you'd need.

    @slicel - Only because the majority of the people don't know how to compile using Slitaz and the steps required. On the rare occasion it doesn't work at all, it just means the program needs to be properly patched or is either too new or too old. Some may require additional steps like compiling some requirements as well.
  • grandagranda March 2011
    Oh man, i done!!
    slitaz-toolchain was installed, but slitaz-dev-pkgs not.
    After installing slitaz-dev-pkgs, i have successful compiled slitaz.
    Well, thx (:

    Sorry about my english, i'm brazilian (:
  • sscoutsscout March 2011
    I'd still like a package, since I'm running it from RAM and an old system with 160mb, I can't install gcc++ (or even java).


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social