This is the old SliTaz forum - Please use the main

Soundcard not detected!
  • skralljtskralljt November 2009
    I think the chipset is fairly common for my card but after installing the new cooking (after my previous installation was constantly hanging at the gui login for a few months), I can't get sound working. When I try to run alsamixer after installing all alsa related programs, it says "cannot open mixer: no such file or directory.
    Then when I try to open alsaplayer, a huge list of errors follows about how no card is found. When I look at proprietary drivers from the system menu snd_cmipci is detected but it just says "missing module!" I could have told it that! How can I get the module and load it?
    On an unrelated note, this new forum sure is clumsy! May as well just do a threaded newsgroup or something.
  • skralljtskralljt November 2009
    Oh I should also mention, I have the Turtle Beach Montego ddl, with 24/96 and all of that.It works well under xubuntu. It's a great card except for its lack of midi.
  • skralljtskralljt November 2009
    Also, when following directions for adding users to a group:
    After adding a user and then
    adduser user -G audio
    it says login 'user' is in use. How should I proceed? This has not changed after a reboot.
  • jozeejozee November 2009
    recharge and upgrade your system again. Sound problem has been fixed in kernel pkg
  • skralljtskralljt November 2009
    nope, it says no new packages. The problem with no sound still exists.
    alsaplayer on the commandline shows:
    snd_pcm_open No such file or directory
    Failed to initialize plugin
    alsalib failed to find card 0
    etc etc etc
    Also, when I try to open alsamixer it says no such file or directory. Do you think my installation is just bad, like the alsa utils package failed to install properly?
  • skralljtskralljt November 2009
    More interesting: When I issue command: modprobe snd_cmipci
    I receive this:
    insmod: cannot insert '/lib/modules/':unknown symbol in module
    modprobe: failed to load module snd_cmipci: no such file or directory.
  • jozeejozee November 2009
    download linux-sound pkg from and test again. No problem modprobing snd-cmipci on my comp.
  • skralljtskralljt November 2009
    Ok, after tazpkg get-install linux-sound --forced, it still didn't work but installing your package worked! Thank you so much! I vow to bring some other linux nerd out of the wilderness in your honor.
  • skralljtskralljt December 2009
    Interestingly after tazpkg recharge tazpkg upgrade last night (which involved an alsa upgrade) and rebooting, slitaz said that it couldn't find my soundcard again. alsamixer is not found. alsa-utils is already installed.
  • skralljtskralljt December 2009
    After force installing linux-sound, in hardware detection it still says there is a missing module for snd_cmipci.
  • skralljtskralljt January 2010
    After doing a tazpkg upgrade and getting the new linux-sound and x.36 kernel, cmipci is still not working.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social