This is the old SliTaz forum - Please use the main

resolv.conf permissions change upon disconnecting from wvdial [SOLVED]
  • ms3811ms3811 November 2010
    I noticed that after everytime I use wvdial to connect to the Internet through a 3G dongle, any attempts to connect to the Internet thereafter would fail. After looking around a bit, I realized that I could connect as a root, however a normal user could not.
    more /etc/resolv.conf

    results in a 'permission denied' error. If I manually enable 'read' for group as well as other users (root permissions do not change), then I can connect again.

    Turns out everything is fine till the point wvdial establishes connection. You can browse, et al. When you hit CTRL+C on wvdial to disconnect, permissions for resolv.conf changes to root(rwx) and nothing for everyone else.

    I did not see this problem with stable (I'm using the latest cooking).
  • erniaernia November 2010
  • ms3811ms3811 November 2010
    That was it. Adding umask 022 to the beginning of both the scripts solved it. Sorry, I should looked a little harder in the forums.

    So I guess this issue went away in stable and is back now in cooking?
  • erniaernia November 2010
    don't worry :-)
    i found it in cooking last month, as far as i know it's only a cooking problem
    please, put solved in topic title to help others searching for solution
  • ms3811ms3811 November 2010
    sure thing. thanks again.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social