This is the old SliTaz forum - Please use the main

Is OpenOffice installed?
  • rocknrollmouserocknrollmouse October 2009
    See if it is in /usr/share, or in Menu/Preferences/Desktop_icons where you can add icons to the desktop manually.

    If not, use package installer to remove get-openoffice and start over, or use --forced in xterm.
  • rocknrollmouserocknrollmouse October 2009

    When I try to run get-OpenOffice3 I get the message "OpenOffice 3 is already installed" (I think I originally ran this some time ago - not log after initially installing Stitaz); however I do not have any OpenOffice icons on my system - either on menu or desktop.
    Can someone advise is there a step I'm missing after running get-OpenOffice3 before I can use it?

    Many thanks
  • rodrigorodrigo October 2009
    I get some problems running get-flashplugin directily from root terminal.
    The problem was solved by uninstalling the script from tazpkg utility. And to I follow the same path.
    I remove the script and reinstall it. Then the was installed with no error reporting.

    Try this way and let me know your experience.
    I think that this I'll work fine for you to.

  • rocknrollmouserocknrollmouse October 2009
    hanks folks, but sadly no further forward yet.

    slicel I think I've followed your advice, please see below.

    rodrigo your advice sounded right, but don't have the knowledge to know the commands to follow it (as you'll see from what I did below, its all recorded basically, as this is my level of knowledge).

    Before starting checked what is already there (as per locations given by slicel):
    Nothing in usr/share, but in Menu/Preferences/Desktop_icons I found program names (eg openoffice.org3-writer), but no icon or description.

    Using Package Manager (gui) I removed and re-installed get-OpenOffice3.

    After this I found two files:

    From the command prompt:
    Running get-OpenOffice3 (as su) gave the "OpenOffice3 is already installed" message;

    tazpkg install OpenOffice3-3.1.1.tazpkg
    Gave the longer message "OpenOffice3-3.1.1 is already installed. You can use the --forced option to force installation or remove it and reinstall."

    tazpkg install OpenOffice3-3.1.1.tazpkg --forced
    Gave installation output (copying; extracting; installing...) no errors reported. Interestingly for each of the OpenOffice programs it reported ".desktop File exists" eg:
    ln: openoffice.org3-base.desktop: File exists
    and finally:
    OpenOffice3 (3.1.1) is installed.

    However I can still not find any OpenOffice program files or icons that I could use to run.
  • rodrigorodrigo October 2009
    Package Manager (gui) = "tazpkg utility"...

    Try once more... Remove with --force option, like this:
    >>> $ tazpkg remove OpenOffice3-3.1.1.tazpkg --forced
    >>> $ tazpkg remove get-OpenOffice3 --forced
    And in tazpkg utility reinstall the "get-OpenOffice3" script with shure that the option "auto install dependences" are setted.
    In slitaz 2.0, soon as you get installed the script, the package manager execute it and install That was the way for me.

    Post your return...
  • slicelslicel October 2009
    If you see it in Desktop_icons, use Desktop_icons to put an icon on the desktop and then click the icon to open the program.

    If someone can tell us what name openoffice uses in xterm, type the name in xterm and press enter to try to run the installed program and see any messages.
  • rocknrollmouserocknrollmouse October 2009
    Hi rodrigo,

    Thanks for the reply, some "interesting results from the un-install:
    $ tazpkg remove OpenOffice3-3.1.1.tazpkg --forced
    response was:
    OpenOffice3-3.1.1 not installed.

    $ tazpkg remove get-OpenOffice3 --forced
    did remove :-)

    Looked for the "auto install dependences" option but can't find it in Packages Manager, or should I be running tazpkg from the command line?

    Hi slicel,

    In desktop_icons most programs are listed with three components:
    an icon; program name; description

    For my OpenOffice program lines I have:
    no icon; program name; no description

    So although I can highlight an OpenOffice program when I click [+ Add] nothing happens!
  • slicelslicel October 2009
    Do everything to remove or install openoffice as root (login as user root, or in xterm enter su and then the root password).

    Delete the openoffice .desktop file if the --forced removal does not do it.

    Installing get packages through the package manager should have two options and you should check both, auto-execute (run the get package) and auto-install dependencies.

    If the package manager or xterm --forced commands complete but do not show any icons, edit or make a .desktop file, using existing .desktop files as a model.

    Example -
  • teotl31teotl31 January 2010
    i have the same problem but i find all archives in /root/ and all archives are in .rpm how to install that?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social