This is the old SliTaz forum - Please use the main

Intel 865g enable dri workaround
  • rustysmooverustysmoove October 2010
    I have a Compaq Evo D310v with i82865g on-board video. I installed mesa, mesa-dri, mesa-dri-intel, xorg-x86-video-intel and linux-agp then rebooted. when i do glxinfo | grep render as tux i get back software rasterizer if i do it as root i get back opengl renderer string Mesa DRI Intel 845g. so as user no hardware accel for games. root works no problem for games.

    I then did # addgroup tux video and restarted. same deal though. no user hardware acel.

    I then did LIBGL_DEBUG=verbose glxinfo | grep render. which led me to the file /dev/dri card0 cannot open. so I checked permissions and only root has them for that file.

    so I changed permissions with pcmanfm as root to allow user read+write permission then restarted . same deal no accel went back to folder no permission again

    so I did chmod 666 /dev/dri/card0. restarted, still no permission after restart.
    Works great for user as long as I don't restart.

    Then I tried adding sudo chmod 666 /dev/dri/card0 to rcS.conf file to run at boot. but it says it
    cannot find the file.

    I'm at a loss as to how to make the change stick without having to pcmanfm or chmod it at every startup.
  • mojomojo October 2010
    This is another part of slitaz that needs fine tuning.
    When card0 is created by system it should be a member of video group not root group.
    Then all regulars users who are member of video group could open card0.
    Because it's part of root group tux has to be part of root group to open it.
    Personally I am not obsessed with security,adding new users,and spending hours trying to get things to work on slitaz that I know are broken.
    I addgroup tux root so tux can open /dev/dri/card0
  • rustysmooverustysmoove October 2010
    well that sounds like it would work but security goes out the window. there has to be a better way.
  • mojomojo October 2010
    root@slitaz: nano /etc/udev/rules.d/50-udev-default.rules

    Add whats in bold:

    # graphics
    KERNEL=="agpgart", MODE="0600", GROUP="video"
    KERNEL=="pmu", GROUP="video"
    KERNEL=="nvidia*|nvidiactl*", GROUP="video"
    KERNEL=="card[0-9]*", NAME="dri/%k", GROUP="video"
    SUBSYSTEM=="graphics", GROUP="video"
    SUBSYSTEM=="drm", GROUP="video"


    tux@slitaz:~$ ls -l /dev/dri/card0
    crw-rw---- 1 root video 226, 0 Oct 11 00:06 /dev/dri/card0

  • rustysmooverustysmoove October 2010
    thanks for the help mojo I will give it a try
  • kultexkultex October 2010
    to add tux to the group root is not a very good idea

    the problem is described here:

    in the section DRI / DRM Problem

    you just have to do as root

    # rm /dev/dri
    # mkdir /dev/dri/

    and it should work without problem
  • mojomojo October 2010
    Thanks kultex for prompting me to review the guide.

    There was a different solution already posted there.

    If you have DRI/DRM enabled, it may be easier to change its permission so all users can use it, rather than adding each to the video group. Append the following section:

    Add to /etc/Xll/xorg.conf

    Section "DRI"
    Mode 0666


    tux@slitaz:~$ ls -l /dev/dri/card0 
    crw-rw-rw- 1 root root 226, 0 Oct 12 13:05 /dev/dri/card0

  • rustysmooverustysmoove October 2010
    I did the
    # rm /dev/dri
    # mkdir /dev/dri/

    and only root had read+write permissions
  • kultexkultex October 2010
    very strange - and you use stable or cooking?
  • rustysmooverustysmoove October 2010
    stable 3.0
  • kultexkultex October 2010
    thx rustysmoove and mojo

    sorry, that I was not reading carefully - you solved something, where jozee and I gave up - see here: - quite the end of the thread

    @mojo you could ad this to the guide

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social