This is the old SliTaz forum - Please use the main

[NEWBIE NEED HELP] "GLX" missing, failed for OpenGL
  • stopstockstopstock September 2010
    Hi all, i am totaly noob on linux.
    i choosed slitaz it cause small and tiny :)

    i used slitaz for graphic design. Gimp, Inkscape, Blender.

    but i've a problem.
    when i typed "blender" on terminal

    GLX, OpenGL not found
    Compiled with Python version 2.5.1.
    Checking for installed Python... got it!
    Xlib: extension "GLX" missing on display ":0.0".
    intern/ghost/intern/GHOST_WindowX11.cpp:177: X11 glxChooseVisual() failed for OpenGL, verify working openGL system!
    X Error of failed request: BadWindow (invalid Window parameter)
    Major opcode of failed request: 18 (X_ChangeProperty)
    Resource id in failed request: 0xb7820053
    Serial number of failed request: 21
    Current serial number in output stream: 22

    and till this present day, i never used blender on my slitaz :(

    this is my PC spec
    Processor : AMD64 socket am2
    Ram : 1gb
    HD : no I dont have any HD (i used USB FlashDisk as Slitaz LiveUSB)
    Vga : onboard (Nvidia Gforce 6100 405) share memory 256mb

    i hope you all here can help me. thanks :)
  • KillerkaninchenKillerkaninchen September 2010
    You have to install the package "nvidia" to use OpenGL.

    EDIT: Sorry, I didn't see this:
    >HD : no I dont have any HD (i used USB FlashDisk as Slitaz LiveUSB)
  • stopstockstopstock September 2010
    Yes i was installed nvidia package.
    i used slitaz 3.0

    in terminal i typed 'tazhw setup nvidia'
    and than installed nvidia 190.42_2.6.30.6 from rom

    and this is the nvdia screen

    but why OpenGL still not working?

    (sorry for my bad english)
  • Trixar_zaTrixar_za September 2010
    You're going to need the mesa and mesa-dev packages too. Technically mesa can run without the need for nvidia and can be modified to fit the chipset you got by installing the package that nearest to it. Do a tazpkg search mesa to see all of them.
  • stopstockstopstock September 2010
    i typed 'tazpkg search mesa'

    this is the result :

    Installed packages
    libglu-mesa 7.4.4 development
    mesa 7.4.4 x-window
    mesa-demos 7.4.4 development
    mesa-dev 7.4.4 development
    4 installed package(s) found for : mesa

    Available packages name-version
    14 available package(s) found for : mesa

    but i'm sorry i still don't know what should i do?
    i hope i got an experience from this case.
  • Trixar_zaTrixar_za September 2010
    Strange... I do see one mesa package missing though - the one called libglw-mesa-7.4.4
    You could also try installing mesa-dri - not sure if it helps though. I had a similar issue compiling for OpenGL until I installed mesa, mesa-dev, libglw-mesa, lib-glu-mesa and mesa-dri-sis (I have a sis chipset for my graphics card).

    Btw, where did you get the blender package? If it's a cooking package then it won't work with SliTaz 3 - It may need newer dependencies that's only available in the latest snapshot version
  • KillerkaninchenKillerkaninchen September 2010
    The mesa-packages providing opengl are libglu-mesa and libglw-mesa but I think installing mesa-dri is also a good idea.
    But I think the devel-packcages are needed for compiling only...?!
  • stopstockstopstock September 2010
    still not working :(
    btw, i used SlitaZ 3.0 and used 3.0 package

    mesa-dri not working :(

    I surf on google and I found this link.

    they have the same problem with me. but they are using ubuntu.
    and many of them were successfully fixed their problem.
    but I'm confused. how to do it on slitaz?
  • stopstockstopstock September 2010
    btw what is the difference from Slitaz 3.0 and Slitaz Stable version?
    why they had the same name? am I did the wrong thing?
  • KillerkaninchenKillerkaninchen September 2010
    >mesa-dri not working :(
    What does it say?
  • stopstockstopstock September 2010
    I'll check it after I got home.
    at this time, I am currently in the internet rental for download Slitaz.iso :)
  • stopstockstopstock September 2010
    Forgive me, I mean OpenGL still not found after I installed mesa-dri

    and nvdia driver can't installed on my slitaz.

    this is the error message:

    WARNING: Skipping the runlevel check (the utility `runlevel` was not found).

    ERROR: You appear to be running an X server; please exit X before
    installing. For further details, please see the section INSTALLING
    THE NVIDIA DRIVER in the README available on the Linux driver
    download page at

    ERROR: Installation has failed. Please see the file
    '/var/log/nvidia-installer.log' for details. You may find
    suggestions on fixing installation problems in the README available
    on the Linux driver download page at
  • stopstockstopstock September 2010
    thanks guys. the problem has been successfully fixed.
    I don't know what's the difference from Slitaz 3.0 and Slitaz Stable.

    but yesterday I download Slitaz stable. and reinstall my Slitaz on my USB

    first i do 'tazhw setup nvidia'

    and then I do install :

    (note : i do install nvidia 190.42_2.6.30.6.tazpkg when get-install mesa-dev still in progress)

    and then I typed 'tazx' and choosed install or reconfigure xorg.
    and restart my x session.

    now OpenGL can working fine :)
    and I can run Blender 3D.

    thank you guys, for your advice and your help :)

    (forgive me for my bad english)
  • KillerkaninchenKillerkaninchen September 2010
    I never tried a live-usb. I don't know if it is possible to install video-driver and mesa using a live-system, but the error messages sound like a faulty driver installation. I installed nvidia via tazpkg package manager...
  • KillerkaninchenKillerkaninchen September 2010
    Too late...
  • babaorumbabaorum September 2010

    @stopstock :

     I don't know what's the difference from Slitaz 3.0 and Slitaz Stable.

    There is no difference : Slitaz 3.0 is the latest stable release ; 2.0 and 1.0 were the previous ones. "cooking" version always represents the most recent up-to-date but unstable release.


  • mojomojo September 2010 march 14, 2010 march 28, 2010 september 7, 2010

    This is rather confusing:
    slitaz-cooking.iso is older than stable-3.0.iso
    slitaz-core.iso seems to have taken over from slitaz-cooking.iso as the most up-to-date unstable release

  • Trixar_zaTrixar_za September 2010
    I assume slitaz-core is the latest cooking version (it reports itself as cooking), while the current slitaz-cooking version is the pre-slitaz 3 version.

    slitaz-ore runs pretty well as a liveCD and has better support for devices than 3, but from a recent experience with it, it's installer is still pretty buggy - not to mention other things like the distro completely ignoring ppp connections.
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social