This is the old SliTaz forum - Please use the main

Network-Monitor does not automatically display active interface
  • ms3811ms3811 September 2010
    This issue has probably been raised a few times before in this forum, but I couldn't really find a solution anywhere. Is this a known issue, or am I the only one facing this. I have atleast 4 laptops running Slitaz, and this issue is consistent across all of them. To elucidate the problem, Network-Monitor applet in the task bar displays 'Unknown' for the active connection by default. When any interface establishes connection, the applet still continues to display 'Unknown' with little red cross. You have to manually click on the applet, then switch the active to connection to eth1 or ppp0 of whatever is presently connected to get it display properly.
  • babaorumbabaorum September 2010
    I have the same problem, ms3811, but it has suddenly solved by itself, w/o any valuable and obvious reason, two times already.
    Sometimes the parsing of the interface "broke" and I got a "eth" non existing interface, rather than eth0 (as it should be on my computer).
  • ChristopheChristophe September 2010
    same here.
    I find it very annoying and was close to reinstall
    In fact, i already had to reinstall once because it could not find my network interface anymore.
  • babaorumbabaorum September 2010
    Network interface parsing occurs at boot in /etc/init.d/ after kernel initialization.
    More precisely in the start() bash function :
    # change default lxpanel panel iface
    sed -i "s/iface=.*/iface=$INTERFACE/" /etc/lxpanel/default/panels/panel

    I cannot guess why it sometimes fails...
  • ms3811ms3811 September 2010
    As mentioned in @ernia's post, I've tried amending to update lxpanel, but it doesn't work. Even if succesfully updates the value for iface in /home/$i/.config/lxpanel/default/panels/panel, the applet does not reflect the change.

    This issue is not limited to boot up alone. E.g. if you establish a ppp connection post startup, the applet needs to reflect the active connection as ppp0 which it doesn't. Also, eth1 more often than not, takes a few seconds after boot up to procure an ip, and I think finishes executing much before.
  • kultexkultex September 2010
    I Think, you can avoid this problem by switching to wicd - at least on one of my computers this worked ...
  • ms3811ms3811 September 2010
    So I followed the guide and installed wicd, it looks a lot more configurable. However, I'm having an issue getting it to connect using WPA2 with AES. Googled this quite a bit with no luck neither is there any information on this issue in this forum.
  • ms3811ms3811 September 2010
    Ok, so that didn't quite work out for me. Spent the whole day trying to get wicd working with WPA2/AES with no luck. I might just have to go back to Network-Monitor. Better a computer that connects but doesn't say so, than one that just doesn't.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social