Russian http://vanilla.slitaz.org/index.php?p=/categories/ru-general/feed.rss Tue, 19 Jun 18 10:26:15 +0200 Russian en-CA Привет всем http://vanilla.slitaz.org/index.php?p=/discussion/1352/privet-vsem Fri, 04 Jun 2010 11:14:01 +0200 devl547 1352@/index.php?p=/discussions Для начала можно представиться.
Александр, студент из Москвы. В slitaz с версии cooking 2.0.
Занимаюсь тут в основном добавлением программ в репы.]]>
Asus Eee PC 901. Все вопросы. Обмен опытом. http://vanilla.slitaz.org/index.php?p=/discussion/2673/asus-eee-pc-901.-vse-voprosy.-obmen-opytom. Mon, 07 Mar 2011 13:29:08 +0100 Diogen 2673@/index.php?p=/discussions Привет Всем !

В Линуксе я ноль, поэтому интересно всё, но особенно то, что у меня не работает. Прошу помочь.

Итак, добился я следующего:

установил Slitaz на второй 7,5 ГБ диск второй системой после семёрки, на раздел 130 МБ, заняла 100 МБ, форматировал ext2.

Загружаюсь по клавише Esc выбирая второй. Грузится после редактирования menu.lst на sdb2. Семёрка не грузится не через Grub,

не через восстановленный MBR, но меня это не волнует - собирался сносить.


А теперь, внимание, вопрос: как наладить WiFi ?

Драйвер rt2860 показывает загружен, что-то сканирует, но ни одной точки доступа не видно. Под семёркой (с диска 3,5 ГБ) всё работает.

С неё сейчас и печатаю.

Попутно, зайти под tux не удалось. Менял пароль, не помогло. Но этот вопрос не очень "горячий" :)

Главное WiFi.


Спасибо.


]]>
FreeRDP и Remmina http://vanilla.slitaz.org/index.php?p=/discussion/2598/freerdp-i-remmina Wed, 16 Feb 2011 13:04:21 +0100 malamut 2598@/index.php?p=/discussions ]]> запуск скриптов при старте http://vanilla.slitaz.org/index.php?p=/discussion/2023/zapusk-skriptov-pri-starte Tue, 09 Nov 2010 12:12:00 +0100 webgid 2023@/index.php?p=/discussions найти скрипт, который бы добавлял переключатель раскладки клавиатуры

setxkbmap "us,ru" ",winkeys" "grp:ctrl_shift_toggle,grp_led:scroll"

только в .sh]]>
не работает eth0 на eeepc 1001px http://vanilla.slitaz.org/index.php?p=/discussion/1758/ne-rabotaet-eth0-na-eeepc-1001px Tue, 07 Sep 2010 15:26:36 +0200 Onion 1758@/index.php?p=/discussions После длительного гугления добавил модуль atl1c в переменную load modules, проблема стала несколько иной: теперь при запуске eth0 находится, но он лежит. При выполнении команды
#ifconfig eth0 up

возникают следующие эффекты:
1) если сетевой кабель подключен - то все виснет намертво. Совсем. Спасает только перезагрузка.
2) если кабель не подключен - все проходит нормально, интерфейс поднимается. Но стоит включить сетевой кабель, как опять-таки все виснет.

В loaded kernel modules отображает:
snd_hda_intel
atl1c
Т.е., как я понимаю, все работать должно, но че-то как-то не то.
В чем может быть проблема и какие пути ее решения?]]>
Проблема с установкой с USB http://vanilla.slitaz.org/index.php?p=/discussion/2255/problema-s-ustanovkoy-s-usb Fri, 17 Dec 2010 08:49:19 +0100 AVK 2255@/index.php?p=/discussions
Просьба помочь решить пролемку:

Пытаюсь установить эту ОС с флешки, которую подготовил с помощью программки tazusb.exe.
И вот неутешительный результат:

Loading /boot/bzImage...................
Loading /boot/rootfs.gz........................
Decompressing Linux ..........
..........(many messages)
Trying to unpack rootfs image as initramfs
Switched to NOHz mode on CPU #0
.............(pause about 2-3 min)
..........(many messages)
[] kernel_thread_helper+0x7/0x10
(код в кавычках c0103927)

После этого все зависает и можно либо питание выключить, либо Сброс нажать

Попробовал другие опции при загрузке:

boot: slitaz irqpoll no387 sound=no sound=noconf modprobe=ide-generic

Железо следующее:
Процессор - AMD Geode GX466(333MHz)
Чипсет - AMD CS5535
ОЗУ - 128MB
HDD - IDE Flash Card 2 GB
]]>
Slitaz-3.0 invalid boot disk http://vanilla.slitaz.org/index.php?p=/discussion/2162/slitaz-3.0-invalid-boot-disk Wed, 01 Dec 2010 07:14:46 +0100 AMG 2162@/index.php?p=/discussions в чем может быть проблема?
несколько раз прожигал образ
на разных компьютерах пробовал
результат отрицательный.
:-(]]>
Пакеты http://vanilla.slitaz.org/index.php?p=/discussion/1660/pakety Tue, 17 Aug 2010 08:00:11 +0200 devl547 1660@/index.php?p=/discussions А то портировать по спискам pkgsrc и gentoo packages не столь интересно.]]> Новый Cooking 20101104 http://vanilla.slitaz.org/index.php?p=/discussion/2004/novyy-cooking-20101104 Fri, 05 Nov 2010 02:05:50 +0100 Lexeii 2004@/index.php?p=/discussions загрузить новую версию Cooking с одного из официальных зеркал проекта. Мы очень ждем ваши отзывы в нашей почтовой рассылке либо на официальном форуме.
]]>
Xorg (no screens found) http://vanilla.slitaz.org/index.php?p=/discussion/2157/xorg-no-screens-found Tue, 30 Nov 2010 15:48:29 +0100 FTA 2157@/index.php?p=/discussions "
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
"
весь лог достаточно большой, для выкладывания сдесь (1700+) прямая ссылка:
http://www.easyload.ru/download/?34296
как это обойти?
п.с.
кстати xorg на других системах работает без таких ошибок о0 (debian 5.0, ubuntu 9.10 \ 10.10, archlinux)
ноутбук toshiba satellite l300-110, чтобы также не юзали гугл:

Display
size : 15.4 "
type : Toshiba TruBrite® WXGA TFT High Brightness display
internal resolution : 1,280 x 800
]]>
модем Sierra 595u http://vanilla.slitaz.org/index.php?p=/discussion/2109/modem-sierra-595u Tue, 23 Nov 2010 23:27:51 +0100 imp 2109@/index.php?p=/discussions Поставил wvdial, полез соединяться (юсб модем sierra 595u). Оказывается, что
Cannot open /dev/ttyUSB0 - no such file or directory...
Хм, действительно его нет. Позаимствовал у Lighthouse Pup 5.0. Обнаружилось устройство Sierra Wireless Inc 595u.
Другая загвоздка - Missing module sierra.ko. Снова стянул у пупсика. Гы - неправильный, говорит, модуль!
Да, ядро-то 33е. Подскажите, а с 30го не подойдет ли?]]>
Еще один кусочек русификации http://vanilla.slitaz.org/index.php?p=/discussion/2057/esche-odin-kusochek-rusifikacii Mon, 15 Nov 2010 10:28:06 +0100 Lexeii 2057@/index.php?p=/discussions
Какую локаль я использую?
$ export
...
export LANG='ru_RU'
export LC_ALL='ru_RU'
...

Когда я меняю в содержимом mime-файлов «ru» на «ru_RU», я получаю то, что нужно!
Я написал маленький скрипт (запускать от root) для того, чтобы не править руками огромное количество файлов:
# sed -i -e 's/xml:lang="ru"/xml:lang="ru_RU"/g' \
`find /usr/share/mime -name *.xml`
(Этот скрипт можно набрать и в одну строчку, тогда в конце первой строки не пишите символ «\» и не нажимайте «Enter». Это только для узкой колонки форума).

Также я пробовал заменять «ru» на «ru*» для универсальности, но это не сработало (mime-файлы скрипт изменил, конечно, но я по-прежнему получал английские описания).

Моя папка с файлами локализации: /usr/share/locale/ru/LC_MESSAGES

Итак, у нас есть 2 варианта решения:
  1. изменить «ru» на «ru_RU» в mime-файлах;
  2. изменить «ru_RU» на «ru» в названии локали (возможно ли это?)

Я просматривал файлы в /usr/share/mime, не все из них имеют описания на многих языках. Некоторые из них не были включены в исходный ISO SliTaz и пришли ко мне с установленными пакетами. Многие файлы содержат внутри строку:
<!--Created automatically by update-mime-database. DO NOT EDIT!-->


Когда я запускаю с правами root
# update-mime-database /usr/share/mime
мои mime-файлы изменяются (обновляются дата и время файлов), но я не вижу изменений внутри файлов.

Получается так, что нам всё-равно нужно вручную редактировать все mime-файлы (в пакете «shared-mime-info» и других)? Интересно, как дела обстоят с другими языками? А, может, кто-то видел русские типы файлов и без этих плясок?

Как временное решение мой скрипт годится, дальше ждем ответа разработчиков. Этот текст я отправлял в список рассылки по-английски, теперь решил поделиться с русской частью сообщества.]]>
Перевод документации вики http://vanilla.slitaz.org/index.php?p=/discussion/1512/perevod-dokumentacii-viki Sun, 18 Jul 2010 14:42:00 +0200 Lexeii 1512@/index.php?p=/discussions Кирилл Шевцов в соответствующей теме форума высказал желание заниматься переводом статей вики SliTaz. Вскоре к нему присоединился Сергей (Onion).

Кроме переведенных когда-то мною и Иваном (ivanscm) пары страниц теперь имеются такие странички:
  1. Руководство
  2. Использование Live CD
  3. Рабочий стол
  4. Основные команды
  5. Установка
  6. Доступность
  7. Офисные приложения
  8. Интернет
  9. Графика
  10. Разработка
  11. Мультимедиа
  12. Система
  13. Пакеты
  14. Настройка сети
  15. Системные утилиты
  16. Безопасность
  17. Модификация SliTaz Live CD
  18. Tazpkg — менеджер пакетов
  19. Secure Shell (SSH)
  20. Утилиты
  21. Оконные менеджеры
  22. LiveUSB
  23. Создание Live CD
  24. Окружение chroot
(И этот список растет со временем!)

Я приглашаю всех, у кого есть способности к переводу, заняться переводом статей. Я упрощаю вашу задачу тем, что вам не нужно изучать синтаксис вики (хотя он сам по себе и не сложен) — статьи я размещу сам.

Присылайте мне свои переводы!
Все заинтересованные пишите в этой теме или присылайте мне личные сообщения.]]>
неприятные мелочи при установке http://vanilla.slitaz.org/index.php?p=/discussion/1844/nepriyatnye-melochi-pri-ustanovke- Fri, 01 Oct 2010 19:44:27 +0200 Tot_koWo_neT 1844@/index.php?p=/discussions при установке с /home отдельным разделом
slitaz-installer предлагает отформатировать раздел (что естественно). только вот в случае согласия. раздел форматируется но запись в него не происходит (не создается домашний каталог пользователя) скрипт выводит много ругани вроде "не могу найти файл"и тд
в случае если отказаться от форматирования -всё пучком.
моё железо (если это важно) pent-3, мать HP p/n D9820-60009, винт wd 80гб sata (через китайский переходник)

еще напрягает строка при старте системы "Starting udev daemon...Failed"
хотелось бы узнать с чем это связано и как это исправить.

ну и обновление ядра не дописывает новое ядро в grub/menu.lst мелочь, а неприятно
]]>
Изменение разрешения экрана http://vanilla.slitaz.org/index.php?p=/discussion/1349/%D0%98zmenenie-razresheniya-ekrana Fri, 04 Jun 2010 07:07:32 +0200 kov_serg 1349@/index.php?p=/discussions На компьютерах с nVidia и DVI разъёмом. Всё прекрасно нажимаем Ctrl+Alt+Backspace выпадаем в из Xorg
пишем tazx потом statx и всё хорошо.

Но что делать если это не помогает?
использовать xrandr ( он предлагает очень ограниченный список 640x480 и 800x600 )
tazpkg get-install xorg-xrandr
xrandr -s 640x480

или править вручную /etc/X11/xorg.conf
используя утилиту gtf установки
#gtf 1024 768 100
Modeline "1024x768_100.00" 113.31 1024 1096 1208 1392 768 769 772 814 -HSync +Vsync

ctrl+alt+plus и ctrl+alt+minus ?

Есть ли какой нибуть slitaz-овский метод для изменения разрешения и частоты развёртки?
]]>
Перепись линуксоидов http://vanilla.slitaz.org/index.php?p=/discussion/1914/perepis-linuksoidov Sun, 17 Oct 2010 09:50:13 +0200 Onion 1914@/index.php?p=/discussions http://www.dudalibre.com/gnulinuxcounter?lang=en

А вы уже посчитались?:))]]>
Печать по локальной сети http://vanilla.slitaz.org/index.php?p=/discussion/1840/pechat-po-lokalnoy-seti Thu, 30 Sep 2010 13:05:36 +0200 Syncmaster 1840@/index.php?p=/discussions Вопрос, как установить его в систему по умолчанию ? Если можно, пошагово.]]> Не грузится SliTaz 3.0 с диска LiveCD http://vanilla.slitaz.org/index.php?p=/discussion/1705/ne-gruzitsya-slitaz-3.0-s-diska-livecd Thu, 26 Aug 2010 16:58:52 +0200 bar 1705@/index.php?p=/discussions Samsung N220 intel video http://vanilla.slitaz.org/index.php?p=/discussion/1688/samsung-n220-intel-video Sun, 22 Aug 2010 22:54:38 +0200 vampi 1688@/index.php?p=/discussions Вобщем устанавливаю систему запускаю tazx выбираю драйвер intel он вроди бы как качает модули,
пробую подключать их через modprobe , запускаю startx и вижу тупо черный экран:(((]]>
Хранитель экрана, лок экрана, спящий режим. http://vanilla.slitaz.org/index.php?p=/discussion/1641/hranitel-ekrana-lok-ekrana-spyaschiy-rezhim. Fri, 13 Aug 2010 23:11:39 +0200 memfis 1641@/index.php?p=/discussions ну и наконец Самба, Samba http://vanilla.slitaz.org/index.php?p=/discussion/1650/nu-i-nakonec-samba-samba Sun, 15 Aug 2010 14:44:47 +0200 memfis 1650@/index.php?p=/discussions 1. чтобы запускались искы
2. Опенофис
3. для мастдайных апологетов, поставщиков файлов, которые только под Эксель\Аксесс запускались - сотв. наборы wine или кроссовера
4. cups
5. для тех, кто не вписывается в п.3 - Virtualbox (например, всякие Citryx, клиенты которых, несмонено, есть и под linux, но вот пользовталеьские настреочные скачиваемые файлы поставщиками родятся под win)
6. samba.
7. факультативно - всякие спящие режимы, которые, скорее, есть зло в смысле безопасности (при загрузке Слитаза за 20 сек. на морально устаревшем asus s5 от 2004г. быстрее загрузиться, чем подняться из спящего режима)
8. только для меня и приближенных - шифрование пользовательских каталогов от ядра

Т.е. остался п. 6. Сам сервер запускается "влет". А вот чем увидеть аналогичные сетевые ресурсы? В Уб там есть гребанный кнфликтующий с самбой вариант через Наутилус. А здесь чем? вчастности, CUPS должен увидеть расшаренный сетевой smb принтер. КАК?]]>
ext4 http://vanilla.slitaz.org/index.php?p=/discussion/1633/ext4 Fri, 13 Aug 2010 11:23:49 +0200 memfis 1633@/index.php?p=/discussions Попытка предварительной разметки диска в ext4 с последующей установкой Slitaz провалилась - он все равно все переформатировал в ext3.

Какие будут мысли?]]>
Ставим OpenOffice. http://vanilla.slitaz.org/index.php?p=/discussion/1644/stavim-openoffice. Sat, 14 Aug 2010 20:16:02 +0200 memfis 1644@/index.php?p=/discussions
Так вот об OpenOffice. В пакетном менеджере есть get-OpenOffice. Однако он вылетает с ошибкой, поскольку версия ОО обновилась, а он ищет старую по имени файла, да и язык ее не наш.

Решение простое - скачиваем OpenOffice http://www.freetorrent.fr/download.php?id=ebd1aafdefd5ba3a158e3b878589c55c99a1eb56&f=OpenOffice%203.0.1%20US%20installation%20package%20for%20SliTaz.torrent, это готовый слитаз-пакет (http://forum.slitaz.org/index.php/discussion/1611/openoffice)

Решение не простое - можно взять с http://ru.openoffice.org/about-downloads.html, версию Linux (RPM). Распаковать, войти в директорий rpms, засунуть туда отредактированный штатный файл get-OpenOffice3.

Я поудалял места про скачивание. Оставил цикл распаковки rpm, сборки пакета Слитаза. Пакет сделался. Офис запускается, но только не из штатного меню. Из исходного ОО размером 180мб собрался пакет 102мб.
Могу выложить, если кому надо. Это будет третье решение.]]>
Wi-Fi, штатный менеджер сетей http://vanilla.slitaz.org/index.php?p=/discussion/1634/wi-fi-shtatnyy-menedzher-setey Fri, 13 Aug 2010 11:25:15 +0200 memfis 1634@/index.php?p=/discussions
Какие будут идеи?
]]>
Virtualbox http://vanilla.slitaz.org/index.php?p=/discussion/1632/virtualbox Fri, 13 Aug 2010 11:21:17 +0200 memfis 1632@/index.php?p=/discussions
root@VEU:/home/veu# /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module ...done.
Removing old VirtualBox netadp kernel module ...done.
Removing old VirtualBox netflt kernel module ...done.
Removing old VirtualBox kernel module ...done.
Recompiling VirtualBox kernel module ...done.
Starting VirtualBox kernel modulesleep: invalid number '.2'
...failed!
(Cannot change owner vboxusers for device /dev/vboxdrv)

Решение содержалось в http://forum.slitaz.org/index.php/discussion/comment/4932/#Comment_4932.

Даже патч запускать оказалось не надо, достаточно было изначально ставить ВиртуалБокс не из репрозитория, а командой get-virtualbox, если уже был ранее поставлен, то сам удалится и сам поставится. Т.е. от root вводим в терминале:
get-virtualbox

и наслаждаемся результатом. Как выяснилось, лишь до первой перезагрузки. Потом требуется /etc/init.d/vboxdrv setup:

VERR_VM_DRIVER_LOAD_ERROR (rc=-1910)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

]]>
Вопрос по скриптам http://vanilla.slitaz.org/index.php?p=/discussion/1525/vopros-po-skriptam Fri, 23 Jul 2010 05:42:31 +0200 Onion 1525@/index.php?p=/discussions понадобилась прога, чтобы устанавливать pppoe-соединение не из консоли, а нажатием одной кнопки.
Изучив примеры из /usr/share/examples приступил к кодингу. Получилось вот что:

#!/bin/bash
#
# SliTaz pppoe-starter
# ver 0.1
# (c) Onion, 20100722

status_check
{
if [ -f /var/run/pppoe.conf-pppoe.pid.pppoe ]
then
STATUS="ON"
else
STATUS="OFF"
fi
}

status_check

export MAIN_DIALOG='
< window title="pppoe-starter" icon-name="network-transmit-receive">
< vbox>
< text use-markup="true" width-chars="25">
< label>"< b>PPPoE-starter< /b>"< /label>
< /text>
< text wrap="true"use-markup="true">
< label>(c) Onion, ver 0.1< /label>
< /text>
< text use-markup="true">
< variable>TEXT_STATUS< /variable>
< label>"< b>'$STATUS'< /b>"< /label>
< action>status_check< /action>
< action>refresh:TEXT_STATUS< /action>
< /text>
< button>
< label>PPPoE start< /label>
< input file icon="gnome-netstatus-rx">< /input>
< action>pppoe-start< /action>
< action>status_check< /action>
< action>refresh:TEXT_STATUS< /action>
< /button>
< button>
< label>PPPoE stop< /label>
< input file icon="network-offline">< /input>
< action>pppoe-stop< /action>
< action>status_check< /action>
< action>refresh:TEXT_STATUS< /action>
< /button>
< /vbox>
< /window>
'
gtkdialog --center --program=MAIN_DIALOG

exit 0
(пробелы после < вставлены, чтобы корректно отображался код)
Собственно, вопрос. Как сделать так, чтобы при подключении( а соответственно при создании файла /var/run/pppoe.conf-pppoe.pid.pppoe, проверка которого проводится при старте и при нажатии на кнопки ) менялся текст, обозначенный TEXT_STATUS?

Прогу пишу для себя, и скорее, чтобы научиться писать под слитаз, но и на практике я ее уже тоже применяю.]]>
Два монитора http://vanilla.slitaz.org/index.php?p=/discussion/1372/dva-monitora Wed, 16 Jun 2010 08:31:55 +0200 Syncmaster 1372@/index.php?p=/discussions Нужно расширить рабочий стол на второй монитор. С настройкой linux практически не знаком, поэтому затрудняюсь решить данную проблему самостоятельно.
Имеется:
1. Видеокарта ATI RADEON HD 4350 (RV710)
2. Монитор SyncMaster 172B
3. Монитор SyncMaster 152T

При попытке автоматической установки драйверов ATI Radeon через Tazhw box и последующей перезагрузки, xserver отказывается запускаться.

Xrandr установил. Где находится xorg.conf также знаю. ]]>
К сожалению, какие-то проблемы с форумом http://vanilla.slitaz.org/index.php?p=/discussion/1351/k-sozhaleniyu-kakie-to-problemy-s-forumom Fri, 04 Jun 2010 07:52:47 +0200 kov_serg 1351@/index.php?p=/discussions
в частности попробуй в консоле набрать "Привет Волку!" а потом стереть с помощью backspace.
xterm*utf8: 1 -- не помогает :(

Нано итак собрано с utf8.

nano --version
GNU nano version 2.0.9 (compiled 18:03:24, Feb 24 2010)
(C) 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007
Free Software Foundation, Inc.
Email: nano@nano-editor.org Web: http://www.nano-editor.org/
Compiled options: --enable-color --enable-extra --enable-multibuffer --enable-nanorc --enable-utf8


В slitaz всё собирается по рецептам с помошью tazwok. для nano рецепт такой

# SliTaz package receipt.

PACKED_SIZE="100.0k"
UNPACKED_SIZE="332.0k"
PACKAGE="nano"
VERSION="2.0.9"
CATEGORY="utilities"
SHORT_DESC="GNU Nano Text Editor."
MAINTAINER="pankso@slitaz.org"
DEPENDS="ncursesw"
BUILD_DEPENDS="ncursesw-dev"
TARBALL="$PACKAGE-$VERSION.tar.gz"
WEB_SITE="http://www.nano-editor.org/"
WGET_URL="http://www.nano-editor.org/dist/v2.0/$TARBALL"
TAGS="text-editor"

# Rules to configure and make the package.
compile_rules()
{
cd $src
./configure \
--prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--sysconfdir=/etc \
--enable-all \
--enable-extra \
--enable-utf8 \
$CONFIGURE_ARGS &&
make &&
make DESTDIR=$PWD/_pkg install
}

# Rules to gen a SliTaz package suitable for Tazpkg.
genpkg_rules()
{
mkdir -p $fs/usr/share $fs/etc
cp -a $_pkg/usr/bin $fs/usr
cp -a $_pkg/usr/share/nano $fs/usr/share
# Config file.
cp stuff/nanorc $fs/etc
}

Грабли именно с терминалом, а не с nano.
]]>
Русификация консоли http://vanilla.slitaz.org/index.php?p=/discussion/1347/rusifikaciya-konsoli Fri, 04 Jun 2010 06:49:47 +0200 Lexeii 1347@/index.php?p=/discussions http://forum.slitaz.org/index.php/discussion/1209/slitaz-ru/#Item_16
Погуглив на предмет этой ошибки, предполагаю, что в setfont баг, либо он не понимает шрифты psfu, а только psf.
Вопрос остается открытым.]]>
Поддержка UTF-8 в xterm и nano (решено) http://vanilla.slitaz.org/index.php?p=/discussion/1350/podderzhka-utf-8-v-xterm-i-nano-resheno Fri, 04 Jun 2010 07:12:36 +0200 Lexeii 1350@/index.php?p=/discussions Хочу здесь описать то, что я давно уже решил, но, может, кто-то об этом еще не знает. Итак.
Терминал и еще много чего упорно не будут отображать utf-8.
Чтобы такого не было, для терминала в файл ~/.Xdefaults нужно вписать строчку
xterm*utf8:     1
После этого терминал практически «из коробки» будет работать с UTF-8 (тут разработчики недосмотрели).
Этот файл есть в /root/, а для tux`а его можно скопировать оттуда и изменить владельца/группу.

Для того, чтобы консольный редактор nano работал с UTF-8, его нужно заменить. Компилировать программы я пока не собираюсь, я просто нашел в интернете пакет nano-2.2.4-1.i386.rpm и выковырял из него бинарник nano. На счастье, он оказался собран с нужными опциями:
root@slitaz:~# nano --version
GNU nano, версия 2.2.4 (собрано в 03:42:09, Apr 15 2010)
(C) 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007,
2008, 2009 Free Software Foundation, Inc.
Почта: nano@nano-editor.org Сайт: http://www.nano-editor.org/
Собрано с опциями: --enable-color --enable-extra --enable-multibuffer --enable-
nanorc --enable-utf-8
В свете UTF`икации это тоже недосмотр разработчиков.

Mc еще не ставил, как-то с pcmanfm пока не ощущаю потребности. Хотя неплохо было бы иногда входить в архивы как в папки и просматривать двоичные файлы.
]]>